First time here? Check out the FAQ!
1

"Move Program Counter Here" command not available when debugging script in a docker container

I'm debugging various scripts running in a docker container. I can debug them fine following the instructions in here https://wingware.com/doc/howtos/docker However, the "Move Program Counter Here" command, which I often use, is greyed when I debug scripts running in a docker container. The command it's available when debugging a script in the host. I've tried to call the command directly from the "Command by name" option and typing debug-move-counter or debug-move-counter-clicked, which works well when debugging a script in the host, but I get the message Command not found.

I've run the "Reload all scripts" option but it the debug-move-counter is still not available.

How can I make this command available when debugging a script inside a docker container?

martinako's avatar
78
martinako
asked 2020-04-29 17:54:12 -0500
edit flag offensive 0 remove flag close merge delete

Comments

I just tried this with Wing Pro 7.2.2.6 and it does work even with remote development. One possibility is that if you've reached an exception then the command is not available because of limitations in how this is done in Python. Are you at an exception when it doesn't work? And if so, does it work if you instead run to a breakpoint?

Wingware Support's avatar Wingware Support (2020-04-30 16:20:56 -0500) edit

Also note that it's only available in the innermost stack frame...

Wingware Support's avatar Wingware Support (2020-04-30 16:21:54 -0500) edit

I'm using wingide6. There is no exception and it's innermost stack frame. I use that command often. I have just tried to use the debug-move-counter command for the example in the howto link in my question, just with a few extra print statements to jump between them. I can stop at a break point but the debug-move-counter command it's not available there either.

martinako's avatar martinako (2020-04-30 17:42:22 -0500) edit

I've done the same steps with wingide7 and I can use the debug-move-counter command there without problem. So the problem I describe in this question seems to be wingide6 specific.

martinako's avatar martinako (2020-05-01 05:16:34 -0500) edit
add a comment see more comments

1 Answer

0

It looks like this was a bug that was fixed in version 7.0.3.3 so indeed it won't appear in the latest version of Wing 7.

Wingware Support's avatar
4.1k
Wingware Support
answered 2020-05-01 09:39:41 -0500
edit flag offensive 0 remove flag delete link

Comments

add a comment see more comments

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account. This space is reserved only for answers. If you would like to engage in a discussion, please instead post a comment under the question or an answer that you would like to discuss.

Add Answer