First time here? Check out the FAQ!
1

Debugging fails to step, and breakpoints don't break

I'm using Wing 10 Pro (10.0.4.0, currently) on several Windows systems and linux systems. When I set a breakpoint in the code, and choose Step over current statement (F6), the debugger stops and waits on the first breakpoint, as expected. However, in version 10 on one particular Windows 10 machine (not the other Windows computers, nor the linux computers) if other, subsequent breakpoints are set in the file, the debugger will not stop at them. Nor will lines be stepped through one-by-one, but the code will run as far as it can before terminating or hitting an error.

This is a new development. I've tried uninstalling/reinstalling Wing, and then uninstalling Wing and deleting any user Settings directories in AppData\Roaming. Neither worked; on a completely new installation (no previously Settings are being read, so far as I can tell, because the UI is back at the installation defaults) the breakpoint behavior still exists, and F6 doesn't pause debugging as expected.

Is this a known thing, and is there a solution/workaround?

c.oz's avatar
21
c.oz
asked 2024-05-04 19:26:48 -0500
Wingware Support's avatar
4k
Wingware Support
updated 2024-05-24 07:17:39 -0500
edit flag offensive 0 remove flag close merge delete

Comments

1

If you're using Python 3.12, could you try checking the Use Legacy Tracer Core with Python 3.12+ in the Debugger > Advanced page of the Preferences dialog?

Wingware Support's avatar Wingware Support (2024-05-05 09:36:23 -0500) edit
1

That's perfect, and resolves my issue on the "problem" computer. I've also changed to Python 3.12 on another computer, triggered the issue there, and then resolved it with your solution. I apologize for not mentioning the version of Python -- that should have been some context you were given.

Thank you very much!

c.oz's avatar c.oz (2024-05-05 09:55:41 -0500) edit

Could you try the 10.0.4.1 update? You should be able to get it by using Help > Check for Updates. Remember to uncheck the Use Legacy Tracer Core with Python 3.12+ preference when trying it.

Wingware Support's avatar Wingware Support (2024-05-08 13:02:14 -0500) edit

Done. I tried that update with the Use Legacy Tracer Core with Python 3.12+ preference both checked and unchecked, and have seen no real difference (though haven't been looking for them carefully). Both ways seem to work well here, with my limited testing. Thank you.

c.oz's avatar c.oz (2024-05-10 09:21:38 -0500) edit

Does the update (10.0.4.1) work with Use Legacy Tracer Core with Python 3.12+ preference unchecked on the machines where debugging did not work with 10.0.4.0?

Wingware Support's avatar Wingware Support (2024-05-10 09:31:33 -0500) edit
add a comment see more comments

1 Answer

0

This should be fixed as of Wing 10.0.4.1

Wingware Support's avatar
4k
Wingware Support
answered 2024-05-24 07:17:28 -0500
edit flag offensive 0 remove flag delete link

Comments

add a comment see more comments

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account. This space is reserved only for answers. If you would like to engage in a discussion, please instead post a comment under the question or an answer that you would like to discuss.

Add Answer