Ask Your Question

Revision history [back]

There is a problem in Wing 8.0.4.1 and earlier that prevents the Packages tool from updating if using pip 21.3. This will be fixed in the next release and can be worked around by replacing src/external/pipdeptree.py in the Wing installation with the latest from https://github.com/naiquevin/pipdeptree

However, I'm not seeing failure to create a virtualenv in that case so I think that is a separate issue. Seeing another bug report right after trying to and failing to create a virtualenv may show us what is going wrong.