Ask Your Question

Revision history [back]

I think the problem is the following:

debug1: remote forward failure for: listen 46443, connect 127.0.0.1:46443 
Warning: remote port forwarding failed for listen port 46443

Wing is trying to set up a reverse SSH tunnel so that its remote agent can connect from the Raspberry Pi back to the IDE. Without the tunnel, nothing will work.

This is probably due to tunneling being disabled in the sshd configuration on the Raspberry Pi. I think this is the AllowTcpForwarding option in the sshd_config file - the default is yes to allow it, but maybe for some reason you have it set to no.

If you want to test this out, you can try a reverse tunnel from the command line outside of Wing:

ssh -v -R 20000:127.0.0.1:20000 192.168.1.17

This should also show that forwarding is failing with the same kind of message. Adding more -v's to the command line might indicate the reason for the failure (more -v's make it more verbose, up to 3 of them.

This is how it's done with OpenSSH, which seems to be what you are using. PuTTY on Windows is slightly different, I think.