Ask Your Question
1

Wing HTML help has font too large

asked 2018-09-18 14:01:00 -0600

gary bollenbach gravatar image

updated 2019-03-13 10:30:49 -0600

Hi All,Just started using Wing 6.1 Personal, and I notice the title problem. This is Mint 19 VM at rez 2880 x 1800.  The usual problem at this resolution is font too small but for some reason this case is the opposite. Right clicking and reducing to minimum font size doesn't get there. I would like to see two or three smaller font size choices (unless I'm missing something?). Screen capture available if you want it.thanks,GB  

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2019-03-16 12:11:05 -0600

Note that Wing 7 now does a considerably better job with high DPI displays.

edit flag offensive delete link more
0

answered 2018-10-12 10:15:00 -0600

updated 2020-12-10 08:27:19 -0600

We'll try to replicate and fix this.  My guess is the DPI is reported high and the code we're using to display help is doubly compensating for that, probably because Qt isn't consistent in what it's doing).  A work-around would be to view the docs on our website for now.One thing that would be useful if you're willing is to see if you also have problems like this with the release from http://wingware.com/wingide/early Thanks for reporting this problem!

edit flag offensive delete link more
0

answered 2020-12-08 03:08:27 -0600

am70xk gravatar image

I am currently using wing personal 7.2.7; I have a new laptop with 4k resolution, namely 3840×2160 , and the IDE shows fine; but I would prefer to use a lower resolution, namely the standard 1980×1080 , because otherwise I cannot use the attached screen (the difference in resolution makes the attached screen useless...); when I switch resolution, wing fails to understand the new DPI, and all fonts are double the correct size; to solve this I have to halve the sizes of the fonts; just FYI

edit flag offensive delete link more

Comments

What OS is this on?

Wingware Support gravatar imageWingware Support ( 2020-12-08 08:52:48 -0600 )edit

Ubuntu Bionic

am70xk gravatar imageam70xk ( 2020-12-10 04:14:17 -0600 )edit

Just in case, did you enable HiDPI setting in QT? see https://stackoverflow.com/a/36058882/...

am70xk gravatar imageam70xk ( 2020-12-10 04:15:01 -0600 )edit

Yes., Wing has hiDPI turned on but the Qt support for this is a mess and I think we've layered some hacks on top of that to get things working right. We're upgrading to a newer Qt in Wing 8 (but not current or next alpha release) which may help with this eventually.

Wingware Support gravatar imageWingware Support ( 2020-12-10 08:31:02 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-09-18 14:01:00 -0600

Seen: 1,366 times

Last updated: Dec 10 '20