Ask Your Question
1

Wing101 and Tcl/Tk

asked 2017-05-02 13:21:00 -0600

Sanjeev Joshi gravatar image

updated 2019-03-13 10:18:28 -0600

Here is my current environment:

macOS: 10.12.4
Wing 101 version: 6.0.4-1, which uses Tcl/Tk version 8.5.??
Python and IDLE version: 3.6.1, which uses Tcl/Tk version 8.5.18

Every time I run code in Wing 101 that uses Turtle graphics, it does run in the Turtle window, but I cannot close the window. If I click the red (close window) button, the beachball spins endlessly. I had to 'force quit' it. If I run the same code in IDLE,  the code runs flawlessly and I can close the window after graphics are rendered.

  1. It is annoying to 'force quit' the window every time. Why it is happening in Wing 101?

  2. How can I tell Wing 101 to use the latest version of Tcl/Tk, 8.6.4, which I have installed?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2017-05-02 13:42:00 -0600

updated 2019-03-07 07:13:50 -0600

Wingware Admin gravatar image

It is annoying to 'force quit' the window every time. Why it is happening in Wing 101?

If you're running it in the Python Shell, then restarting the shell should close the window.  You can probably just check on the Auto-restart When Evaluate File in the Python Shell's Options menu so this happens automatically. If you're debugging, killing the debug process or restarting debug should close the old window.

How can I tell Wing 101 to use the latest version of Tcl/Tk, 8.6.4, which I have installed?

 Set the Python Executable in Configure Python from the Source menu to the value of sys.executable in IDLE (do 'import sys' followed by 'sys.executable' to see that).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-05-02 13:21:00 -0600

Seen: 477 times

Last updated: Mar 07