First time here? Check out the FAQ!
1

How to turn off 'smart indenting' in a doc string?

Hi,

I tried changing the Tab Key Action, and Smart Tab End, but it has no effect.

Inside a doc string, when I tab after the :param par_01_s:, in order to input a comment, the tab just stops. It won't tab any further, it just stops. In some cases, when the comment already exists, a Tab action results in bringing the entire line to the left margin.

So I can't line up the comments for all of the variables, in the same column.

How do you shut this off? I want to control the placement of the comments, without assistance from the IDE.

wpCurious's avatar
61
wpCurious
asked 2020-04-05 15:46:34 -0500
Wingware Support's avatar
4.1k
Wingware Support
updated 2020-04-06 07:18:31 -0500
edit flag offensive 0 remove flag close merge delete

Comments

add a comment see more comments

1 Answer

0

It looks like the code that tries to detect whether you're at the end of the line for "smart tab" is not working right within docstrings, probably because it is failing to differentiate the case of being within a logical line from being at the end of a logical line. We'll try to fix this soon.

For now, a way to work around this would be to press Ctrl-T when you want a tab character.

Wingware Support's avatar
4.1k
Wingware Support
answered 2020-04-06 07:21:09 -0500
edit flag offensive 0 remove flag delete link

Comments

Will do, thanks.

wpCurious's avatar wpCurious (2020-04-06 08:52:58 -0500) edit
add a comment see more comments

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account. This space is reserved only for answers. If you would like to engage in a discussion, please instead post a comment under the question or an answer that you would like to discuss.

Add Answer