First time here? Check out the FAQ!
1

Upgrade Python version 2.7.x in WING Personal 7 for Mac OS X Yosemite

I have installed Python v 3.9.x in my Mac OS X Yosemite and installed WING personal v 7.0.x. But the python version is v 2.7.x Help me to upgrade to python v 3.9.x in WING personal v 7.x.x. Thanks

ANDY's avatar
11
ANDY
asked 2020-07-22 10:11:20 -0600
Wingware Support's avatar
4k
Wingware Support
updated 2020-07-22 12:10:04 -0600
edit flag offensive 0 remove flag close merge delete

Comments

add a comment see more comments

1 Answer

0

Wing doesn't support Python 3.9 yet. We'll try to add this soon. We usually do earlier in the beta series, but this is running a bit behind schedule at the moment. Python 3.8 and earlier are supported, however.

Wingware Support's avatar
4k
Wingware Support
answered 2020-07-22 12:09:31 -0600, updated 2020-07-22 12:09:52 -0600
edit flag offensive 0 remove flag delete link

Comments

1

I tried with Python v 3.8. 5 and 3.7.8 but the version of the python in WING still is v 2.7.10. It showed "2.7.10 (default, Jul 14 2015, 19:46:27) "

ANDY's avatar ANDY (2020-07-22 14:57:00 -0600) edit

You may need to set the Python Executable in Project Properties from the Project menu to tell Wing which Python to use. I'm not sure why it's preferring Python 2; it should be trying to use the latest Python by default. It may be you need to restart Wing when you've installed a new Python version to get that to happen (in which case setting Python Executable may not be necessary) or if you're really using Wing Personal 7.0.x and not 7.2.3 then perhaps it's a bug we've fixed since then. I'd recommend using the latest Wing version.

Wingware Support's avatar Wingware Support (2020-07-22 17:34:03 -0600) edit
1

Thank you for your help, I got it by setting in Project Properties.

ANDY's avatar ANDY (2020-07-23 07:48:53 -0600) edit

Great, I'm glad that solved it. I see we changed some things in Wing 8, in how we scan for Python, and I think that may fix what you ran into so the latest Python is used.

Wingware Support's avatar Wingware Support (2020-07-23 07:59:53 -0600) edit

My Mac is old, maybe it does not work with latest version. 7.0 is fine for me now. Thank you again.

ANDY's avatar ANDY (2020-07-23 09:39:32 -0600) edit
add a comment see more comments

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account. This space is reserved only for answers. If you would like to engage in a discussion, please instead post a comment under the question or an answer that you would like to discuss.

Add Answer