First time here? Check out the FAQ!

Trouble setting up WSL

I have a trial version of WingIDE Pro version 7 running on Windows 10, and I'm trying to set up programming with WSL, by following the instructions at When I entered the command

plink saul@MyNook "mkdir .ssh; chmod 700 .ssh"

I got the error message

FATAL ERROR: No supported authentication methods available (server sent: publickey)

I went over to Ubuntu and made the .ssh directory with the appropriate permissions, but when I entered the next command

plink saul@MyNook "sed -i -e '$a\' .ssh/authorized_keys"

I got the same error message.

Can you tell me how to troubleshoot this? I know that the SSH server is running, but I really don't know anything about PuTTY or SSH. Thanks.

saul's avatar
asked 2021-03-16 11:48:47 -0500
edit flag offensive 0 remove flag close merge delete


add a comment see more comments

1 Answer


I figured it out. I needed to edit the /etc/ssh/sshd_config file as follows:

Change PasswordAuthentication to yes (and uncomment the line)

At the end of the file I added the line

AllowUsers saul

Now I have to see if I can use Wing on WSL.

saul's avatar
answered 2021-03-16 13:15:27 -0500
edit flag offensive 0 remove flag delete link


See also - In particular, with WSL you need to uncheck Use SSH Tunnel for username@localhost under the Advanced tab of the remote host configuration.

Also PuTTY's pscp.exe has a bug that requires setting SSH Port under the Options tab of the remote host configuraiion in Wing, even if using port 22. Otherwise the remote agent install fails because pscp.exe is trying to connect to port 0.

And I think ssh can also be particular about the permissions on files inside .ssh in some cases, even if .ssh is chmod 700.

Wingware Support's avatar Wingware Support (2021-03-16 14:23:01 -0500) edit
add a comment see more comments

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account. This space is reserved only for answers. If you would like to engage in a discussion, please instead post a comment under the question or an answer that you would like to discuss.

Add Answer