Ask Your Question
1

Increase timeout for remote debugging

asked 2021-09-19 11:39:37 -0500

qwerty_ww gravatar image

updated 2021-09-20 09:13:44 -0500

I have set up a project to run a remote debugger on a Pi Zero. Basically it works. Basically. That is, the remote Python is started and the process runs. However, I rather soon get a timeout and that's it. But where can I increase that timeout?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2021-09-20 09:13:01 -0500

The Network > SSH Timeout and Network > Hung Connection Timeout preferences may be relevant if it's actually timing out. Also if it's specifically the debugger timing out then Debugger > Network > Network Timeout preference.

However, it may could also be the debug process is crashing or something else. To diagnose this, send a bug report from Wing's Help menu with the error log included right after replicating the bug. Then also immediately send ~/.wingpro8/remote-agent.log (or ~/.wingpro7/remote-agent.log if using Wing 7) from the Pi Zero. We may then also ask for debugger-specific logging, but those two are the start at diagnosing problems like this.

edit flag offensive delete link more

Comments

1

Yep, I found it. Always hard if you have so many option. Unfortunately, or luckily, the error did not re-occur after rebooting the Pi. Will refer to this once I get that happan again.

qwerty_ww gravatar image qwerty_ww  ( 2021-09-21 16:40:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2021-09-19 11:39:37 -0500

Seen: 29 times

Last updated: Sep 21