Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

WingIDE on Fedora 26 cant find libSDL-1.2.so.0

fedora 26 workstation, wingpro 6.0.7-1 (rev 47fe5b0dd72b)using Fedora 26 python 3.6.2wxPyton 4.0.0b2'import wx' works finebut"import wx.dataview as dv"  causes an error:File "/usr/lib64/python3.6/site-packages/wx/dataview.py", line 12, in <module>  from ._dataview import *builtins.ImportError: libSDL-1.2.so.0: cannot open shared object file: No such file or directoryso iin the terminal i did:sudo yum import libSDL-1.2.so.0Last metadata expiration check: 0:19:04 ago on Mon 25 Sep 2017 09:59:11 AM -03.Package SDL-1.2.15-24.fc26.i686 is already installed, skipping.Dependencies resolved.Nothing to do.Complete!so it IS installed. so where is wingIDE looking for it?

WingIDE on Fedora 26 cant find libSDL-1.2.so.0

fedora 26 workstation, wingpro 6.0.7-1 (rev 47fe5b0dd72b)using 47fe5b0dd72b) using Fedora 26 python 3.6.2wxPyton 4.0.0b2'import 3.6.2 wxPyton 4.0.0b2

'import wx' works finebut"import fine but"import wx.dataview as dv"  causes an error:File "/usr/lib64/python3.6/site-packages/wx/dataview.py", error:

File "/usr/lib64/python3.6/site-packages/wx/dataview.py", line 12, in <module>  from ._dataview import *builtins.ImportError: libSDL-1.2.so.0: cannot open shared object file: No such file or directoryso iin directory

so in the terminal i did:sudo did:

sudo yum import libSDL-1.2.so.0Last libSDL-1.2.so.0
Last metadata expiration check: 0:19:04 ago on Mon 25 Sep 2017 09:59:11 AM -03.Package -03.
Package SDL-1.2.15-24.fc26.i686 is already installed, skipping.Dependencies resolved.Nothing skipping.
Dependencies resolved.
Nothing to do.Complete!so do.
Complete!

so it IS installed. so where is wingIDE looking for it?

WingIDE on Fedora 26 cant find libSDL-1.2.so.0

fedora 26 workstation, wingpro 6.0.7-1 (rev 47fe5b0dd72b) using Fedora 26 python 3.6.2 wxPyton 4.0.0b2

'import wx' works fine but"import wx.dataview as dv"  causes an error:

File "/usr/lib64/python3.6/site-packages/wx/dataview.py", line 12, in <module>  from ._dataview import *builtins.ImportError: libSDL-1.2.so.0: cannot open shared object file: No such file or directory

so in the terminal i did:

sudo yum import libSDL-1.2.so.0
Last metadata expiration check: 0:19:04 ago on Mon 25 Sep 2017 09:59:11 AM -03.
Package SDL-1.2.15-24.fc26.i686 is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!

so it IS installed. so where is wingIDE looking for it?