First time here? Check out the FAQ!
1

Weird path transformation

Hi all,

when I select project properties and want to define a custom Python Executeable and Python python, I can select this via "Browse". However, after selecting it is transformed to a weird path like this: /run/user/1000/doc/aecf0ab5/python3 (this is not the path I selected before. And it is not existing, too) Ubuntu: Distributor ID: Ubuntu Description: Ubuntu 18.04.3 LTS Release: 18.04 Codename: bionic WingIDE: 7.1.3.2 (rev 3600c9873c6f) WingIDE path: /snap/wing7/9

Any idea how I can fix that? Manually specifying the path works, but is a bit uncomfortable. Cheers, /otc

otc's avatar
11
otc
asked 2020-01-16 04:46:10 -0600
Wingware Support's avatar
4k
Wingware Support
updated 2020-01-16 07:03:47 -0600
edit flag offensive 0 remove flag close merge delete

Comments

add a comment see more comments

1 Answer

0

I think this is an issue with Snap's "classic" confinement model. We've also had reports of the file dialogs not appearing at all with the snap on some Linux systems, but the behavior you see is new so I suspect they've fixed some things but there are still problems. However, I wasn't able to find a bug report yet for this in the Snapcraft bug tracker. I will investigate further after replicating the bug here.

In any case, the work-around is to install from Debian package instead, although note then the executable name will be wing7.1 and not wing7 as from the snap. It's fine to install both at the same time.

Wingware Support's avatar
4k
Wingware Support
answered 2020-01-16 07:19:10 -0600
edit flag offensive 0 remove flag delete link

Comments

OK, thanks a lot!

otc's avatar otc (2020-01-16 08:07:48 -0600) edit

FWIW, it looks like this is not an issue on Ubuntu 19.04 but is a problem on Ubuntu 18.x.

Wingware Support's avatar Wingware Support (2020-01-21 15:01:41 -0600) edit
add a comment see more comments

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account. This space is reserved only for answers. If you would like to engage in a discussion, please instead post a comment under the question or an answer that you would like to discuss.

Add Answer