First time here? Check out the FAQ!
1

SSH Port - The default port 22 doesn't seem to work

Hello

I have seen this problem in pervious versions of Wing Pro, and again now in 7.2.8....

Basically when defining a remote host, leaving the default port as (22) doesn't install the agent files the installs seesm to bomb out...(In my case im using Putty Pageant which is also using 22), however selecting "Use specific port" and changing the value to 22 as in the below image works

image description

Thank you

stephenl's avatar
21
stephenl
asked 2021-01-12 13:16:02 -0500
Wingware Support's avatar
3.9k
Wingware Support
updated 2021-01-15 08:26:14 -0500
edit flag offensive 0 remove flag close merge delete

Comments

add a comment see more comments

2 Answers

0

The short answer for future viewers of this question is that PuTTY 0.71 at least and possibly other versions require adding -P 22 to the command line even in the default case, so it's necessary to set SSH Port to Use Specified Port and 22. Otherwise, Wing does not add a -P to the command line, which is done because it's possible to configure the port outside of Wing also, through putty.exe or in .ssh/config if using OpenSSH. The UI will be changed in Wing 7.2.8.1+ to clarify that default doesn't necessarily mean port 22.

Wingware Support's avatar
3.9k
Wingware Support
answered 2021-01-15 08:28:20 -0500
edit flag offensive 0 remove flag delete link

Comments

add a comment see more comments
0

If you bring up putty.exe, does it have a saved entry for the particular remote host? That can be used to change the port number used to something other than port 22, and I think the above dialog in that case is misleading because it assumes the ssh command line system will use port 22 by default. In fact that's also true for OpenSSH, where a different port can be set in the config file. We'll try to clarify that in any case.

If that's not it, does it work to run plink.exe on the command line outside of to connect to the Rasp Pi without specifying the port number on the command line?

Wingware Support's avatar
3.9k
Wingware Support
answered 2021-01-12 13:28:48 -0500
edit flag offensive 0 remove flag delete link

Comments

putty.exe has multiple hosts defined, all of which are set for port 22

plink.exe without specifing the port number connects without any problems

stephenl's avatar stephenl (2021-01-12 13:55:22 -0500) edit

Could you please send in a bug report from Wing's Help menu right after reproducing the problem? Please include the error log, which will contain the putty commands we've run during the install including any output and errors.

Wingware Support's avatar Wingware Support (2021-01-12 14:06:11 -0500) edit

Also, may be worth trying to see if pscp.exe is also using port 22 by default on the command line outside of Wing. It probably is, but all we're doing when you set SSH Port in the configuration is added '-P <port>' to command lines so the problem isn't making sense yet.

Wingware Support's avatar Wingware Support (2021-01-12 14:07:58 -0500) edit

it seems pscp.exe will only work if -P 22 is added

stephenl's avatar stephenl (2021-01-12 14:28:14 -0500) edit

Interesting... what version of PuTTY is it? I'm pretty sure it should be using 22 by default and it works for me here with PuTTY 0.70 (which is a bit old; 0.74 is current).

Wingware Support's avatar Wingware Support (2021-01-12 14:32:56 -0500) edit
add a comment see more comments

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account. This space is reserved only for answers. If you would like to engage in a discussion, please instead post a comment under the question or an answer that you would like to discuss.

Add Answer