First time here? Check out the FAQ!
1

how to clear file magnification (aka zoom) settings?

Wing does a nice job of remembering what my "zoom" settings were for each file in my project. Very slick.

But of course, I'm never satisfied! Is there a way for me to say "clear all the zoom settings for the different files and just go back to whatever is set in my preferences?"

Chris Curvey's avatar
226
Chris Curvey
asked 2021-09-12 16:04:20 -0500
Wingware Support's avatar
4.1k
Wingware Support
updated 2021-09-14 08:30:41 -0500
edit flag offensive 0 remove flag close merge delete

Comments

add a comment see more comments

1 Answer

0

There's the Edit > Zoom > Reset Zoom menu item but it just resets the zoom for the current file. I'm not sure it even makes sense to do this per-file and am not sure why it was designed that way, or is that one of the things you like?

Wingware Support's avatar
4.1k
Wingware Support
answered 2021-09-13 09:46:50 -0500
edit flag offensive 0 remove flag delete link

Comments

I'm just looking for a way to say, "I got a new monitor and now none of my zoom settings make sense, so let's make every file go back to the factory default and I'll start over." (This happens a lot to me as I work in different locations -- sometimes with a 15" laptop screen, sometimes with a 28" ultrawide, and sometimes with a 50" 4K TV.)

While I'm wishing...is there a way to tell what the current zoom setting is would be awesome, especially if I could get it in terms of point size. That way I could zoom the magnification to what I want, and then just say "make the default setting 8pt" or whatever.

I'm guessing this is somewhere in the .wpr or .wpu files, but I have not gone exploring in there.

Chris Curvey's avatar Chris Curvey (2021-09-13 17:44:05 -0500) edit

This might be a good application for Presentation Mode, which is in the hamburger menu in top right. You can tell Wing to restart with a particular magnification applied to the whole UI. However, currently it's only >= 1.1 due to its original purpose and <1.0 is not allowed, so may not help.

Wingware Support's avatar Wingware Support (2021-09-14 08:28:04 -0500) edit

Actually, also, would it work to just reset the Editor Font in preferences to a smaller size? I think it would still apply the zoom setting but to that smaller size, so that may be another way to work around this. Above requests noted, in any case.

Wingware Support's avatar Wingware Support (2021-09-14 08:30:35 -0500) edit
add a comment see more comments

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account. This space is reserved only for answers. If you would like to engage in a discussion, please instead post a comment under the question or an answer that you would like to discuss.

Add Answer