Remote Agent failed to start

Hello, I have set up a new Raspberry Server under BookWorm. As usual I installed the remote agent from Wing IDE (from a MacBook Pro) and I have got following unexpected error:

Remote Agent failed to start

In the log I found following error:

2024/01/01 18:31:46 2104 - ConnectionRefusedError: [Errno 111] Connection refused

Can you please advise what to do? It have installed the remote agent a few time with no issues and this time I have this unexpected issue.

Please help, thanks, Daniele

dcaccount's avatar
1
dcaccount
asked 2024-01-01 13:58:13 -0600
Wingware Support's avatar
4k
Wingware Support
updated 2024-02-15 09:39:39 -0600
edit flag offensive 0 remove flag close merge delete

Comments

This indicates the Raspberry Pi refused the connection. Are you able to ssh into the Raspberry Pi from the machine where Wing is running? If it's a newly set up Raspberry Pi you may need to turn on SSH in its settings.

Wingware Support's avatar Wingware Support (2024-01-02 05:30:55 -0600) edit

Thanks for your attention. It is a new set up Raspberry Pi but I perfectly ssh into it from the machine where Wing is running using a private key.

The folder .wingpro9 is created in the home folder of the raspberry and it fails when probing the remote agent.

There is something I am missing, please help! Thanks

dcaccount's avatar dcaccount (2024-01-02 05:33:54 -0600) edit

Could you please email the file remote-agent.log from ˜/.wingpro9 on the Raspberry Pi to support@wingware.com, if it is created? Also, please submit a bug report from Wing's Help menu and include the error log where prompted (this is the IDE-side error log). Hopefully between those two we'll be able to see what is going wrong.

Wingware Support's avatar Wingware Support (2024-01-02 14:09:52 -0600) edit
add a comment see more comments