Ask Your Question
1

After saving file after block-comment, editor forgets that it was commented by itself

asked 2022-05-09 09:02:15 -0500

KhazAkar's avatar

Hello!,

I just found issue with block comment with auto-formatting enabled. If you block-comment code, save file and it auto-reformats itself, then when you want to un-comment it, it comments it again and you have 2x ## instead of un-commenting.

edit retag flag offensive close merge delete

Comments

Which auto-formatter are you using?

Wingware Support's avatar Wingware Support  ( 2022-05-09 11:07:59 -0500 )edit

Built-in PEP8

KhazAkar's avatar KhazAkar  ( 2022-05-09 11:11:14 -0500 )edit

It should work if you use one of the PEP 8 styles for the Block Comment Style setting on the Editor page of the Preferences dialog. If it doesn't, please send an example to support@wingware.com

Wingware Support's avatar Wingware Support  ( 2022-05-09 17:35:04 -0500 )edit

Seems that it's only available in Pro version, because I've just opened Personal one and I cannot find something like Block Comment Style on 8.3.1.0 version. How can I do that for Personal version or its not possible at all? I've checked comment-toggle instead of comment-block-toggle and it didn't impose such behavior :)

EDIT: I've just opened Wing Pro 8.3.1.1 on my Linux machine and I cannot see this option, only selection which autoformatter to use on Editor page of the Preferences dialog.

KhazAkar's avatar KhazAkar  ( 2022-05-10 01:25:26 -0500 )edit
1

The Block Comment Style setting should be on the main Editor page of the preferences dialog in both Personal and Pro; note that this page is different than the Editor > Auto-formatting page where auto-reformatting is configured.

Wingware Support's avatar Wingware Support  ( 2022-05-10 10:43:22 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-05-11 04:25:53 -0500

KhazAkar's avatar

Temporarily, when I will be able to figure out w/Wingware Support why this issue happens and is not that easily reproducible (reboot of PC can make it disappear, with proper PEP8 settings in Block Comment Style & Auto-formatter, only to re-appear randomly) I'll provide small workaround :)

comment-toggle works also for block selection, so if you have issues with comment-block-toggle, you can try comment-toggle.

I hope that helps :)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2022-05-09 09:02:15 -0500

Seen: 1,167 times

Last updated: May 19