Ask Your Question
1

WingIDE 7.2.2.0 probe raspberry pi 4 fail

asked 2022-06-23 01:58:38 -0600

mhanuel's avatar

updated 2022-07-15 08:41:44 -0600

Hi, I am trying to remote probe a raspberry pi 4 with latest image from wingIDE, SSH is working but I cannot understand exactly the cause of error. The raspberry is running the lite image so no GUI.

Any advice will be appreiated.

Here is the log:

Connecting to host id NAS failed.

Output received:

OpenSSH_8.2p1 Ubuntu-4ubuntu0.5, OpenSSL 1.1.1f 31 Mar 2020 
debug1: Reading configuration data /etc/ssh/ssh_config 
debug1: /etc/ssh/ssh_config line 19: include /etc/ssh/ssh_config.d/*.conf matched no files 
debug1: /etc/ssh/ssh_config line 21: Applying options for * 
debug1: Connecting to 192.168.1.17 [192.168.1.17] port 22. 
debug1: fd 3 clearing O_NONBLOCK 
debug1: Connection established. 
debug1: identity file /home/mhanuel/.ssh/id_rsa type 0 
debug1: identity file /home/mhanuel/.ssh/id_rsa-cert type -1 
debug1: identity file /home/mhanuel/.ssh/id_dsa type -1 
debug1: identity file /home/mhanuel/.ssh/id_dsa-cert type -1 
debug1: identity file /home/mhanuel/.ssh/id_ecdsa type -1 
debug1: identity file /home/mhanuel/.ssh/id_ecdsa-cert type -1 
debug1: identity file /home/mhanuel/.ssh/id_ecdsa_sk type -1 
debug1: identity file /home/mhanuel/.ssh/id_ecdsa_sk-cert type -1 
debug1: identity file /home/mhanuel/.ssh/id_ed25519 type -1 
debug1: identity file /home/mhanuel/.ssh/id_ed25519-cert type -1 
debug1: identity file /home/mhanuel/.ssh/id_ed25519_sk type -1 
debug1: identity file /home/mhanuel/.ssh/id_ed25519_sk-cert type -1 
debug1: identity file /home/mhanuel/.ssh/id_xmss type -1 
debug1: identity file /home/mhanuel/.ssh/id_xmss-cert type -1 
debug1: Local version string SSH-2.0-OpenSSH_8.2p1 Ubuntu-4ubuntu0.5 
debug1: Remote protocol version 2.0, remote software version OpenSSH_8.4p1 Raspbian-5+b1 
debug1: match: OpenSSH_8.4p1 Raspbian-5+b1 pat OpenSSH* compat 0x04000000 
debug1: Authenticating to 192.168.1.17:22 as 'pi' 
debug1: SSH2_MSG_KEXINIT sent 
debug1: SSH2_MSG_KEXINIT received 
debug1: kex: algorithm: curve25519-sha256 
debug1: kex: host key algorithm: ecdsa-sha2-nistp256 
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none 
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none 
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY 
debug1: Server host key: ecdsa-sha2-nistp256 SHA256:xS0r6L7WUbU19B57Tk0HBUrNz1v6JG50Txjji+/uuBg 
debug1: Host '192.168.1.17' is known and matches the ECDSA host key. 
debug1: Found key in /home/mhanuel/.ssh/known_hosts:7 
debug1: rekey out after 134217728 blocks 
debug1: SSH2_MSG_NEWKEYS sent 
debug1: expecting SSH2_MSG_NEWKEYS 
debug1: SSH2_MSG_NEWKEYS received 
debug1: rekey in after 134217728 blocks 
debug1: Will attempt key: /home/mhanuel/.ssh/id_rsa RSA SHA256:/BEFWE73azgmgV3c9Y8QHPZ+CvjlllAD6/5YeTGAr1A agent 
debug1: Will attempt key: /home/mhanuel/.ssh/id_dsa 
debug1: Will attempt key: /home/mhanuel/.ssh/id_ecdsa 
debug1: Will attempt key: /home/mhanuel/.ssh/id_ecdsa_sk 
debug1: Will attempt key: /home/mhanuel/.ssh/id_ed25519 
debug1: Will attempt key: /home/mhanuel/.ssh/id_ed25519_sk 
debug1: Will attempt key: /home/mhanuel/.ssh/id_xmss 
debug1: SSH2_MSG_EXT_INFO received 
debug1: kex_input_ext_info: server-sig-algs=<ssh-ed25519,sk-ssh-ed25519@openssh.com,ssh-rsa,rsa-sha2-256,rsa-sha2-512,ssh-dss,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,sk-ecdsa-sha2-nistp256@openssh.com,webauthn-sk-ecdsa-sha2-nistp256@openssh.com> 
debug1: SSH2_MSG_SERVICE_ACCEPT received 
debug1: Authentications that can continue: publickey,password 
debug1: Next authentication method: publickey 
debug1: Offering public key: /home/mhanuel/.ssh/id_rsa RSA SHA256:/BEFWE73azgmgV3c9Y8QHPZ+CvjlllAD6/5YeTGAr1A agent 
debug1: Server accepts key: /home/mhanuel/.ssh ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-06-23 08:09:22 -0600

I think the problem is the following:

debug1: remote forward failure for: listen 46443, connect 127.0.0.1:46443 
Warning: remote port forwarding failed for listen port 46443

Wing is trying to set up a reverse SSH tunnel so that its remote agent can connect from the Raspberry Pi back to the IDE. Without the tunnel, nothing will work.

This is probably due to tunneling being disabled in the sshd configuration on the Raspberry Pi. I think this is the AllowTcpForwarding option in the sshd_config file - the default is yes to allow it, but maybe for some reason you have it set to no.

If you want to test this out, you can try a reverse tunnel from the command line outside of Wing:

ssh -v -R 20000:127.0.0.1:20000 192.168.1.17

This should also show that forwarding is failing with the same kind of message. Adding more -v's to the command line might indicate the reason for the failure (more -v's make it more verbose, up to 3 of them.

This is how it's done with OpenSSH, which seems to be what you are using. PuTTY on Windows is slightly different, I think.

edit flag offensive delete link more

Comments

Another thing to try is to use Wing 8.3.2 because there are a huge number of fixes to remote development since 7.2.2.0.

Wingware Support's avatar Wingware Support  ( 2022-06-23 08:09:54 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2022-06-23 01:58:38 -0600

Seen: 117 times

Last updated: Jun 27