Ask Your Question
1

Issue with installation Wing IDE on kali - libpango1.0-0 dependency - libpango1.0-0 vs libpango-1.0-0 (additional '-' )

asked 2018-02-14 07:56:00 -0500

Paweł Krawczyk gravatar image

updated 2019-03-14 08:15:27 -0500

I have some issue with the installation on kali linux and the libpango. I have 'libpango-1.0-0' but it wants "libpango1.0-0" so without a ' - ' before '1'

I tried to instal libpango1.0-0 but I have got (and I already have the 'libpango-1.0-0'):

Package libpango1.0-0 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source

However the following packages replace it: 

libpango-1.0-0 
libpangoft2-1.0-0  
libpangocairo-1.0-0 
libpangoxft-1.0-0

and when I try to instal it I get dependency problems because it wants the name without the ' - '# dpkg -i wingide6_6.0.9-1_amd64.deb

Selecting previously unselected package wingide6.
(Reading database ... 319380 files and directories currently installed.)
Preparing to unpack wingide6_6.0.9-1_amd64.deb 
...Unpacking wingide6 (6.0.9-1) 
...dpkg: dependency problems prevent configuration of wingide6: wingide6 depends on libpango1.0-0 (>= 1.18.0); however:  Package libpango1.0-0 is not installed.
dpkg: error processing package wingide6 (--install): dependency problems - leaving unconfigured
Processing triggers for menu (2.1.47+b1) ...Errors were encountered while processing: wingide6
edit retag flag offensive close merge delete

Comments

The newest one (wingide6 (6.0.9-1))- I've downloaded it yesterday

Paweł Krawczyk gravatar imagePaweł Krawczyk ( 2018-02-14 09:18:00 -0500 )edit

I've installed  older version (5.1.12) with no issues - so looks that the issue is just for the new one 

Paweł Krawczyk gravatar imagePaweł Krawczyk ( 2018-02-14 09:29:00 -0500 )edit

OK, thanks for letting us know.  What version of Kali is it, so we can try it here?

Wingware Support gravatar imageWingware Support ( 2018-02-14 09:59:00 -0500 )edit

np, it's Kali 2017.3 

Paweł Krawczyk gravatar imagePaweł Krawczyk ( 2018-02-14 11:20:00 -0500 )edit

Great, thanks, we'll look at it.  Won't be fixed in 6.0.10, though, because that was already built.  If you do try --force-depends it looks like you may need to uninstall Wing again before each apt-get update, if the link I referenced below is still correct.

Wingware Support gravatar imageWingware Support ( 2018-02-14 13:35:00 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2018-02-14 08:29:00 -0500

updated 2019-03-07 09:00:35 -0500

Wingware Admin gravatar image

What version of Wing is this?  I'm surprised it depends on libpango... I'm fairly sure we don't use that.  Also, I'm fairly sure this is just gratuitous dist-to-dist package renaming, which is the reason Wing tries to depend on nothing except for glibc and a few other things at the low level.  In practice, unfortunately, this is practically a full time job to get right.  I wish Linux would get its act together in this regard.

In any case, I suspect the solution is to force dpkg to ignore dependencies with the --ignore-dependencies flag or --force-depends although the latter might cause problems later as mentioned in https://superuser.com/questions/73927...

Please let us know if this does not help.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-02-14 07:56:00 -0500

Seen: 144 times

Last updated: Mar 07