First time here? Check out the FAQ!
1

Error loading libcrypt [closed]

I searched and clicked through pages and didn't find the answer. I'm on Arch, and I keep getting this error (same with --verbose):

${PKGPATH}/bin/__os__/linux-x64/runtime-python3.9/bin/python3.9: error while loading shared libraries: libcrypt.so.1: cannot open shared object file: No such file or directory
tzoi516's avatar
13
tzoi516
asked 2022-07-12 06:17:50 -0500
Wingware Support's avatar
4.1k
Wingware Support
updated 2022-07-15 08:40:35 -0500
edit flag offensive 0 remove flag reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by tzoi516
close date 2022-07-12 07:53:30.336716

Comments

add a comment see more comments

2 Answers

0

Fixed by ln -s

tzoi516's avatar
13
tzoi516
answered 2022-07-12 07:53:04 -0500
edit flag offensive 0 remove flag delete link

Comments

add a comment see more comments
0

Installing libxcrypt-compat should fix this

Wingware Support's avatar
4.1k
Wingware Support
answered 2022-07-12 09:09:04 -0500, updated 2022-07-12 09:41:42 -0500
edit flag offensive 0 remove flag delete link

Comments

It did. Thanks.

tzoi516's avatar tzoi516 (2022-07-12 09:45:01 -0500) edit
add a comment see more comments